Forum index > Bug report ✓

RTP midi not working with mioXL

All my setup is connected through my mioXL (a mac with RTP, a keystep 37 and other synths using DINs).
I tried using the EssenceFM with RTP but as soon as I hit a note on the keystep, the EssenceFM is playing something else, holds the note(s) and if I use the pitch bend or mod wheel I have many events happening at once.
Each time I have to use the panic button to mute the EssenceFM.
Using the same configuration, I have been able to use the keystep with the mac and the other synths.
If I connect the EssenceFM to the mioXL using midi DIN then it's OK and everything works fine.
Is there something more to do on the EssenceFM to make it work ?
Thanks a lot.
Can you try connecting your EssenceFM this way:

EssenceFM ----- Network Switch/Router ----- Computer

And see if that behaves differently.
We don't know how the MioXL works, but wrong events probably indicates that some unrecognized data is received. If you know a way to record network packets sent by your MioXL, that would be very helpful.
Thank you for the quick response.
I'm off for a few days but will do what you said.
Cheers !
Hi, I'm back.
I tried connecting the EssenceFM directly to my Mac using RTP, no luck.
I think I managed to capture something... I played only C4 notes.
Using the MsgMonitor, I get this: 90 30 for note on and 80 30 for note off.
Thank you for the report, we found the problem and fixed it in the upcoming firmware
Cool ! No problem 😉